WordPress 5.5.1 Released with Backfill for Deprecated JavaScript Globals

WordPress 5.5.1 was released yesterday with 34 bug fixes, 4 enhancements, and 5 bug fixes for the block editor.

Version 5.5 removed 19 legacy JavaScript localization objects, in favor of using the new functions and utilities found in the i18n package introduced in WordPress 5.0. One of the most notable changes in this maintenance release is the inclusion of a backfill for these now deprecated JavaScript globals, which were causing errors with many popular plugins and themes.

“If we only count plugins or themes with more than 100k installs or more, some of these already have an incredible impact, which is why we decided to patch this as fast possible.” Joost de Valk said in an update compiling a list of affected extensions, with the the help of Omar Reiss.

Themes impacted include Astra (1 million+ installs), Storefront (200k+), Hestia (100k+), and dozens more. A small selection of the popular plugins that were impacted include Advanced Custom Fields (1 million+), SiteOrigins Widgets Bundle (1 million+), AMP for WP, (100k+), WooCommerce Services (1 million+), Ocean Extra (600k+), and Rank Math SEO (400k+).

Theme and plugin developers still need to update their code to use wp.i18n but in the meantime the legacy code will not block JavaScript execution. De Valk said the new plan is to remove this fallback code in two major versions, so developers need to have their code updated by the time WordPress 5.7 rolls around in 2021. 

“It sounds like a question that also ought to be addressed is how such wide-spread breakage could happen, and how it can be prevented in future,” David Anderson commented on the announcement regarding the backfill. “What part of the release process ought to have flagged up that this was about to happen, how did that part fail, and how can future similar failures be prevented.” Jake Spurlock suggested a retrospective on WordPress 5.5 might be a good idea.

Three weeks after WordPress 5.5 was released, the Enable jQuery Migrate Helper has more than 100,000 active installs. The plugin is available as a stopgap for users who experience problems with jQuery after updating to WP 5.5. Although several bumps along the road are expected for users during WordPress’ process of updating to use the latest version of jQuery, the official support forums were inundated with reports of broken sites after 5.5 was released. Many users found out about the plugin after hours of troubleshooting and hunting for a fix. This is another issue that would be helpful to address in a 5.5 retrospective.

This maintenance release also removes the ability to alter the list of environment types in the new wp_get_environment_type() function. Contributors decided that introducing new types wasn’t the intention of the feature and that it makes it so that theme and plugin developers cannot rely on a set, predictable list of types. They are now limited to production, staging, development, and local, with definitions for each available in the announcement.

“By limiting the set of environment types in this way, WordPress core, plugins, and themes can change their behavior depending on this setting,” Joost de Valk said.

WordPress 5.5.1 also fixes XML sitemaps paginating incorrectly, adds the site environment to debug information, and improves a number of other features that shipped with defects. The full list of changes is available on the release page.

TI ha interessato ciò che hai letto?

Scrivimi e sarai ricontattato quanto prima.

Make an Appointment

for any inquiry

Contattami